There was a bug in Firebird that did not handle well icu > 4.2 see( )

2.1.4 and 2.5.0 packages in distributions were affected (Debian, Fedora,Mandriva, Mageia) because they are using icu 4.4

Adriano fixed it and in these various distro updates are on the way

I know that some of you are using Centos 5.

The problem with Centos 5, is that you can’t have Firebird 2.5 from EPEL repository. Centos 6 will give you the possibility to have Firebird 2.5 from EPEL6 repository, but seems that Centos6 take a long time to come.

You can try to use Scientific Linux instead ( )

As Centos, the base SL distribution is basically Enterprise Linux (RHEL), recompiled from source, and Scientific Linux 6.0 was released on March 3, 2011